Content begins here

Technical Requirements

Setting Up Your System To Use Sakai@UD

  1. Make sure you are using a Sakai-compliant browser (Firefox).
    Safari, Chrome, and browsers on mobile devices have not been tested with Sakai and may not work properly for all tools.
  2. Apply these required browser settings. Note: if you upgrade to a new version of your browser, check to make sure these settings are still correct.

Distance Learners (for UD Online classes)

Optional Add-Ons