Exceed 9/10 for UD

How to Use Exceed

The online version of this document is maintained at:


The document is divided into the following sections. You may read them all or skip immediately to the parts that interest you.

Automatic Software Updates

[top of page]    [next section]

Before using Exceed for the first time, it's a good idea to check for software updates on Hummingbird's website. Exceed includes a tool to do this automatically, called Hummingbird Update. To run it, open the "Hummingbird Connectivity Vx" program group (on the Start menu under programs, or on the desktop), open the System Administration sub-group, and choose "Hummingbird Update". Click "Yes" if prompted to install any updates. It is a good idea to check for updates periodically. Information about important updates will also be posted on the addenda and errata page, as it becomes available.

Starting Exceed

[top of page]    [previous section]    [next section]

There are three ways to connect to remote systems and open X applications with Exceed:

X11 tunneling via SSH is the most secure method. All information passed between your PC and the host system will be encrypted.

Connecting via XDMCP is less secure than SSH tunneling (information sent between the systems is not encrypted), but still provides some measure of security by preventing other users from opening spurious windows on your machine or otherwise interfering with your sessions.

Unmanaged connections (using procedures such as rexec or rlogin) are INsecure, and may allow other users to tamper with your system. In general, it is ill-advised to connect in this fashion unless the host you are connecting to supports neither SSH nor XDMCP.

NOTE to off-campus users: If you connect to the Internet via cable modem or DSL, or you have multiple computers sharing your internet connection and the computer running Exceed is not directly connected to your ISP (this includes Windows' "Internet Connection Sharing", many cable/DSL routers, etc.), then it is possible that only the X11 tunneling via SSH method will work without requiring changes to your home network setup. The tunneling via SSH method will work as long as you are able to open a secure shell session on the remote host. If you wish to use one of the other methods, you may need to contact your ISP's techincal support for help in reconfiguring your equipment.

Tunneling via SSH

This is the most secure method for using Exceed, and is highly recommended. In order to connect via this method, you will need an SSH client which supports X11 tunneling. One such client for Windows is available from SSH.com, and is free for academic and personal use. You can download a copy from the University's software distribution site. The installation is automatic. To enable X11 tunneling:
  1. Run the SSH program.
  2. Click the "Edit" menu and choose "settings".
  3. Click on the "Tunneling" sub-heading (under "Profile Settings")
  4. Check the box next to "Tunnel X11 connections" on the right.
  5. Click the "OK" button.
  6. Click the "File" menu and choose "Save settings".
(For instructions on setting up SSH tunnelling in other SSH clients, refer to the documentation for those clients.)

To run X applications on a remote host and tunnel their output via SSH to Exceed on your PC:

  1. Start the Exceed server in passive communications mode (if you configured Exceed with the recommended settings from the configuring Exceed instructions, it is already set to start in passive mode; otherwise you may need to run Xconfig from the Exceed program menu and change the communication mode).
  2. Run the SSH client and open a shell on the remote machine that you want to run X applications from.
  3. Run the application (e.g. "xterm", "xclock", "xeyes", etc.). If everything is configured properly, the application window should appear on your screen.

Note: SSH tunnelling may slow down your connection slightly on the local network. However, it can provide a significant increase in speed over modem connections if you turn on compression in the SSH client.

[top of page]    [previous section]    [next section]

Using XDMCP to Establish a Session

This method is less highly recommended, but still better than an unmanaged connection (see below). To start an X session using XDMCP:

  1. First, configure Exceed to use XDMCP mode by running Xconfig from the Exceed program group and changing the communication mode. You may choose either "query" or "broadcast" mode. Use "query" mode if you will always connect to the same server - you will have to click the "Configure" button and type in the hostname or IP address of the server. Use "broadcast" mode if you need to connect to more than one server - unless the server is on the same subnet as your PC, you will have to edit the "xdmcp.txt" file in the Exceed user directory (click "Configure" and click "Edit" in the "XDMCP Broadcast" section and add the name of your server to the list).
    Note: If you plan to use one host primarily, but want to use other hosts occasionally, configure Exceed for XDMCP query mode and use the "Exceed XDMCP-broadcast" icon in the Exceed program group when you need to choose a different host.
  2. Start the Exceed server (from the "Hummingbird Connectivity Vx" desktop folder or program group).
  3. If you are using broadcast mode, a box will appear with a list of servers you can connect to - choose the one you want (if it doesn't appear, see the first step) and click "OK".
  4. A login window will appear requesting your username and password. Type your username and press <Enter>, then type your password and press <Enter> (do not press <Tab>!).
  5. If this login process succeeds, any programs you have set to run at start-up should appear (by default you should get a single Xterm window).

[top of page]    [previous section]    [next section]

Using an Unmanaged Connection

This method is not recommended, but may be necessary or expedient if a host you need to use do not support SSH or XDM connections. If you expect to use the this method regularly, consult your department's server administrator or User Services staff to determine ways to improve your system security.

  1. Run Xconfig and in the "Security" sub-menu set "Host Access Control List" to "File". Click the "Edit" button to the right of the "File:" option and add the name of the machine you want to run programs on. Save the file and exit the text editor and click OK in the Xconfig window.
  2. In the Exceed program group (in "Hummingbird Connectivity Vx" on the desktop or in the Program menu), run "XStart". Fill in the information pertinent to this session: at the very least, you need to set the "Start Method" (the default, "REXEC", should work in most cases) and a command. The command must take the form:
          setenv DISPLAY @d; command
    The first part up to the semi-colon sets the display variable on the remote system to point back to your PC. Once that is set, a command can be issued and the specified program should run and display on your PC. For instance:
          setenv DISPLAY @d; xterm
    will open an X-terminal window. Click "Login Info" near the bottom, then click "Run!" in the meun bar.
  3. A login window will appear requesting a host system, your username and password, and an application command. Fill in any fields that aren't already filled in correctly, and click OK.
  4. If the login process succeeds, the program you specified should appear on your screen.
  5. You can save the settings entered in the initial window into a .xs file, so that they can be recalled for future use.

NOTE: If you already have one or more X windows open, attempting to open open additional windows via the method described above will cause a dialog box to pop up stating that the server is already running and asking if you'd like to re-start it. Click No. Clicking Yes will close all of your currently open X windows.

ALSO NOTE: you can not mix unmanaged connections in the same session with XDMCP-managed connections - attempting to start one while the other type is running will require a server reset, which will kill all of your open X windows.

"Housekeeping" Issues

[top of page]    [previous section]    [next section]

The following items address minor configuration settings which you may want to change from the defaults:

Toggling Taskbar / System Tray Icon

You can make the Exceed "X" icon appear in the system tray (bottom left of the screen, near the clock) rather than in the taskbar when the Exceed server is running. To toggle this behavior, right-click on the icon in the tray or taskbar and select the "Tools" menu and then "Show(Hide) Main Icon". Exceed (usually) remembers this setting from one use to the next.

Showing / Hiding the Toolbar

Exceed has a toolbar, which you probably saw pop up the first time you ran Exceed after installation. Once you close it, it will not open automatically on subsequent runs. To re-activate the toolbar, right-click on the Exceed "X" icon in the taskbar or system tray and select "Tools", then "Toolbar", then "Show". You can also customize this toolbar by choosing "Customize" from this sub-menu.

Adding / Removing Components

The "typical" option in the Exceed installer leaves out many non-essential components, and the installation instructions recommend an even further culled set of features. If, after installation, you wish to add or remove components, open the Add/Remove Programs control panel, choose "Hummingbird Exceed Vx", click "Add/Remove" (or "Change" in Windows 2000/XP), choose the "Modify" option, and select the items that you want to add or remove. You will need to re-insert the Exceed CD (or re-extract the installation files if you bought and downloaded Exceed from the web and deleted the installation files after running the installer).
Note: After adding or removing any components, you should re-run Hummingbird Update (see above) to ensure that all components are up-to-date.

Tuning Exceed (XPerf)

When you install Exceed it gives you the option to run XPerf, which attempts to tune Exceed for the best performance for your particular graphics hardware. If you skipped this step, or change hardware, then you may want to run XPerf again. To do so, run XConfig (on the Programs menu under "Hummingbird Connectivity Vx/Exceed"), choose "Other Server Settings" (or "Performance" if you are viewing configuration options in "classic" mode), and click the "Tune" button.

Quitting Exceed and Logging Out

[top of page]    [previous section]    [next section]

All X windows are terminated whenever you exit or restart the Exceed server, regardless of which connection method you use. To exit the Exceed server:

  • If the Exceed "X" icon is in the taskbar, right-click on it and select "Close".
  • If the icon is the system tray, right-click it, choose "File" and then "Exit".
To reset the Exceed server (close all X windows and restart the server), right-click the Exceed icon, choose "Tools", and then "Server Reset".

If your session is managed by XDMCP (see above), you can also shutdown the Exceed server by closing the controlling X window. The controlling window is whichever application is listed last in your .xsession file in your composers account, without a trailing ampersand (&). (If you have the default .xsession file, the last and only application that is started is an xterm window). All other X windows you have opened will be automatically terminated and you will be logged out.

Note: When you are done with your work and ready to quit, make sure that the Exceed server is completely shutdown (no "X" icon in your taskbar or system tray). Otherwise you may inadvertantly leave unwanted processes running on the remote system.

Connecting to Other Systems

[top of page]    [previous section]    [next section]
  • On the University's central systems (Copland, Strauss, and Mahler) you can use the following shortcuts at any shell prompt to open a new program on another of the composers:

    At the shell prompt (%) in an Xterm window, type: onstrauss        to connect to Strauss.
    oncopland        to connect to Copland.
    onmahler         to connect to Mahler.

    These commands are especially useful if you log into copland initially (where you can't run a lot of software, such as compilers) and then want to run something on Strauss/Mahler. The command "onhost" by itself will open an Xterm window. Appending a command (e.g. "oncopland netscape") will run that command on the specified host. These commands will work only if you already have completed the steps outlined in Customizing Your Composers Account. You can create the aliases manually by editing the .alias file in your directory on the composers and add the following lines:

    alias onstrauss 'xrsh -auth none strauss'
    alias oncopland 'xrsh -auth none copland'
    alias onmahler 'xrsh -auth none mahler'

    After you've made the changes, you must type the UNIX command:

    source ~/.alias

    to make the changes take effect (or log out and log back in again).

  • Connecting to other hosts:

    From a shell on any of the composers (or any other system which has xrsh installed), you can open an xterm or other X application on another system by typing:

    xrsh hostname [application]
    (replacing hostname with the target machine's name, and application with an (optional) application to run - if no application is given, an Xterm is opened); or xrsh -l username hostname [application]
    (where hostname and application are the same as above and username is replaced with your username on the target machine) - use this form when your username on the target system is different than your username on the composers).

    To use xrsh, you must have a properly configured .rhosts file on the system to which you are connecting. If xrsh fails, use the special telnet tnxhost alias:

    tnxhost hostname
    (replacing hostname with the machine's name). This alias is created on your UNIX account when you get the special UNIX files described in the document Customizing Your Composers Account.

Warning: using xrsh between the composers is relatively secure because the connections only traverse dedicated paths between those machines. Using xrsh/tnxhost between the composers and other hosts is not recommended, because these connection methods are insecure. X11 tunnelling via SSH is the recommended connection method for all hosts. Using SSH w/tunnelling, you can open multiple secure shell sessions to different hosts simultaneously, and run X applications on each of these hosts.

Middle Mouse-Button

[top of page]    [previous section]    [next section]

X applications that require you to press the middle mouse-button of a 3-button mouse can still be used with a 2-button mouse. Simultaneously press both buttons of your 2-button mouse to emulate the 3-button mouse's middle button. (In order for this third-button emulation to work, it must be turned on in the Exceed configuration. For more information see the Mouse section of Configuring Exceed.)

If you have a wheel mouse, you can press down on the wheel for the third button.

Cut/Copy/Paste Between X and MS Windows Applications

[top of page]    [previous section]

In X applications that run in an Xterm window, you can copy and paste within the same Xterm window or between Xterm windows by first highlighting the section to be copied. Paste the highlighted area into an Xterm window by pressing the middle mouse-button, just as you would on an X-terminal. The pasting occurs at the point designated by the X cursor. Instructions above describe how to press the middle mouse-button when you're using a 2-button mouse.

In Microsoft Windows applications (e.g., Word, Excel) you generally highlight a section and then press Ctrl-X, Ctrl-C, and Ctrl-V to cut, copy, and paste within or between Microsoft Windows application windows. (You may also use the entries on the Edit menu in most applications.)

After customizing your central systems account as described in Customizing Your Composers Account you can also cut, copy and paste between Microsoft Windows and X windows as follows:

  • To copy (or cut) from a Microsoft Windows window to an Xterm window:
    1. Highlight the desired section of the Microsoft Windows window and press Ctrl-C (Ctrl-X to cut).
    2. Click once in the Xterm window (taking care not to highlight anything in the Xterm window) and press Alt-V. There are two Alt keys on most PC keyboards. You must use the one to the right of the spacebar. Alternately, click the middle mouse button (or both buttons if you don't have a middle button or scroll wheel - see above).
  • To copy (or cut) from a Xterm window to a Microsoft Windows window:
    1. Highlight the desired section of the Xterm window, and press Alt-C (Alt-X to cut). Make sure you use the right-hand Alt key! NOTE: do not move the mouse pointer before you press Alt-C (or Alt-X).
    2. Click once in the Microsoft Windows window (or highlight the text to be replaced) and press Ctrl-V.
NOTE: When copying from any X application that runs in its own window (not an Xterm window) you may need to use that program's own cut/copy/paste key combinations. These can be determined from the Edit menu entries for the individual X application.

Copyright © 2004   University of Delaware
Last revised: September 14, 2004