Maple is a comprehensive computer system for advanced mathematics. It includes facilities for interactive algebra, calculus, discrete mathematics, graphics, numerical computation and many other areas of mathematics. It also provides a unique environment for rapid development of mathematical programs using its vast library of built-in functions and operations.

More information about Waterloo Maple Inc. and its products can be found at

Where to Find Maple

  • Where Can I Use Maple on Campus?

    Maple is available on Strauss.

    For availability of Maple at computing sites, please see the web pages at

  • How Can I Obtain Maple for my Personal Computer?

    Please visit our UDeploy software site for Scientific and Research Software.


  • Running Maple Interactively from the Sun Ray Terminals

    Select the Applications > Other > Maple option from the "Applications" pull down menu. The menus will look similar to:

    gnome other menu

    After the introductory screen and possibly the tip-of-the-day screen, you will get the main worksheet window which will look similar to:


    To terminate your Maple session, select the File > Exit option from the Maple menu bar.

  • Running Maple Interactively on Strauss in Line Mode

    Logon to strauss, or open a window on strauss. At the UNIX prompt (%) type



    To end the Maple session, at the Maple prompt (>), type


  • Running Maple Interactively on Strauss with any X Windows System

    Connect to strauss from any X Windows System. At the UNIX prompt (%), type



    To end the Maple X window session, select the File > Exit option from the Maple menu bar.

  • Online Help

    • Line mode

      At the Maple prompt (>), type


      The Help screen, similar to the following one, will appear when looking for plot3d:

    • X Windows

      Select the Help > Topic index option from the Maple menu bar. This opens the Maple help window, with the "Topic" tab enabled.

      The Maple 9.5 Help window, similar to the following one, will appear when looking for plot3d:

  • Printing Maple worksheets in a Single Window

    Plots are normally displayed in the same window as the Maple code and results, the Maple worksheet. See the "Worksheet Interface" section of the "New Users Guide" in the help system for more information.

    A Maple worksheet with one plot command in a single window will look similar to the following.

    maple single window

    To print a Maple worksheet, first click on the titlebar of the window to make sure it is active. Then use the File > Print... menu option to display the Print panel. On the Print panel, check "Print To File", and click the "Print" button at the bottom. This will open the Print To File panel where you enter the path and file name. If you change nothing, it will create the PostScript file in your home directory. Click "OK" to save the file.

    The Maple windows resulting from these steps will look similar to the following:

    maple print window

    Once the PostScript file is saved, you can send it to a printer with

    qpr -q smips

    This will print the file on a PostScript printer in Smith Hall (smips)

    You will need a terminal window to type the qpr command. On a Sun Ray, open a terminal window by selecting "Terminal" from the Applications > System Tools menu. The Gnome desktop menu will look similar to:

    applicatons > System Tools

    In a terminal window, type "qpr -q smips" to print on the Smith I/O printers (illustrated below) or "qpr -q whlps" to print on the 009B Willard Hall printer.

    qpr -q smips

    the qpr command. Specify the printer, any options such as drilled paper, and the file name of your PostScript file. The command

  • Multiple Windows Mode: Getting Started and Printing

    If you want all plots resulting from Maple commands to be in separate windows, you must change the "Plot display" option for "Inline" to "Display". Select Tools > Options... to open the Options panel. Click on the "Display" tab at the top of the Options panel. Using the pull down-menu for "Plot display:", change the option from "Inline" to "Window."  If you want this option to be saved for the current Maple session and future Maple sessions, click the button "Apply to Session" at the bottom of the Options panel:

    The Maple code and plots in multiple windows will look similar to the following


    Notice that the menu options are different when the active window is a plot window. These menu options allow you to customize your plot before you print. These options are also available in a single window configuration if you select a plot within the single window.

    To print any window, first select it to make it active. Then select the File > Print... menu option. Maple windows, similar to the following one, will appear.


    Choose the "print to file" option, and then print the file, as explained above.