How to Customize the Firefox Browser (v. 14.0.1)

You can customize features in Firefox to maximize its use. These instructions are based on using a Windows 7 (Enterprise Edition) computer running Firefox v. 14.0.1. The instructions explain the following:


How to Import Bookmarks from a Different Browser to Firefox

After you have installed Firefox, when you start Firefox for the first time, you will see an Import Settings and Data dialog box asking if you want to import information such as import options and bookmarks from another browser.

NOTE
This is the only time you will have the opportunity to import your settings. Therefore, if you want to keep those settings from another browser, you should import them into Firefox.

The first Import Settings and Data dialog box will look similar to the following:

import settings dialog box

  1. Click the radio button in front of the appropriate browser.
  2. Click Next. You should see a dialog box that looks similar to the following:

home page image

  1. Click the radio button in front of the home page setting you would like to use.
  2. Click Next.
  3. Click Finish.
  4. A progression box will appear. When the import is finished, the box will close.

How to View the Menu Bar

  1. Open Firefox.
  2. Click the orange Firefox drop-down menu in the top-left of the window as indicated by the red arrow in the following graphic:

firefox button

  1. Click Options.
  2. Click Menu Bar. The window will no longer have the drop-down menu, but instead will have the Menu Bar easily accessible across the top of the window as shown in the following graphic:
menu bar view

How to Change the Home Page

  1. Open Firefox.
  2. From the Tools menu, click Options. You will see the Options dialog box that looks similar to the following:

options dialog box

  1. Click the General icon at the top of the window (if necessary). You can set the home page to any location you like.
  2. For example, to set the home page to UD's Webmail log in page, in the Home Page field (upper-most section of dialog box), type
http://mail.udel.edu/
  1. Click OK.

How to Maintain the Security of Your Data

  1. Open Firefox.
  2. From the Tools menu, click Options. You will see the Options dialog box that looks similar to the following:

options dialog box

Click the Privacy icon at the top of the dialog box. The dialog box should now look similar to the following:

privacy options dialog box

  1. If there is a check mark in the checkbox in front of Remember search and form history, click to delete it.
  2. Click the Security icon at the top of the dialog box. The dialog box should now look similar to the following:

security options dialog box

  1. If there is a check mark in the checkbox in front of Remember passwords for sites, click to delete it.
  2. Click OK.

How to Customize the Toolbar

  1. Open Firefox.
  2. From the View menu, click Toolbars.
  3. Click Customize. You will see the Customize Toolbar dialog box that looks similar to the following:

customized toolbar graphic

To personalize the toolbar, you can drag-and-drop the toolbar icons shown in the dialog box into the toolbar at the top of the Firefox window. For example, if the toolbar looked like the following one (with two toolbar icons), you could drag-and-drop the Print icon to the toolbar to avoid using the Menu bar when you want to print.

first toolbar image

  1. Drag-and-drop the Print icon to your toolbar in the location you would like to place it (for example, to the right of the home icon). The toolbar would now look similar to the following (with three toolbar icons):

second toolbar image

  1. Click Done.

How to Install UD Customized Buttons on Your Toolbar

How to Install the UD Help Center Button

  1. You must have javascript enabled for this to work.
  2. Make sure your personal toolbar is showing.
  3. Click and drag the link below onto your personal toolbar.

IT-Help Center

How to Install the UD Proxy Button

  1. You must have javascript enabled for this to work.
  2. Make sure your personal toolbar is showing.
  3. Click and drag the link below onto your personal toolbar.
  4. When looking at a page you would like to have proxified, click the Proxy button.

UD Proxify

How to Install the UD WebMail Direct Button

  1. Click and drag the link below onto your personal toolbar.

WebMail Direct

Setting Your Home Page to the University of Delaware's Home Page

  1. If you see a yellow bar above concerning restricting access to active content, click the bar and choose Allow Blocked Content.
  2. Click Yes in the dialog box to display the active content.
  3. Click and drag the link below to make the University of Delaware your home page.

Drag this Link onto Your Home Button to Make the University of Delaware Your Home Page


How to Configure the Pop-up Blocker Feature

  1. Open Firefox.
  2. From the Tools menu, click Options. You will see the Options dialog box.
  3. Click the Content icon at the top of the dialog box. The dialog box should now look similar to the following:

content options dialog box

  1. Confirm that there is a check mark in the checkbox in front of Block pop-up windows. If there is no check mark, click in the box to enter one.
  2. Click the Exceptions button to the right of the Block pop-up windows option. The dialog box will now look similar to the following:

allow pop-ups window

You can add sites from which you would like to allow pop-up windows. For example, you can add the University's Library site by following these steps:

  1. In the Address of website field, type

www.lib.udel.edu

The dialog box will now look similar to the following:

allow pop-ups from library example

  1. Click Allow. The dialog box will now look similar to the following:

allow library pop-ups example

You can follow the same steps to add more sites from which you would like to allow pop-ups. Sites that you should also add are the following:

  1. Click Close when you finish.
  2. Click OK.

How to Update to New Versions (and patches) of Firefox

You can automate Firefox to check for updates and patches. Follow these steps:

  1. Open Firefox.
  2. From the Tools menu, click Options. You will see the Options dialog box.
  3. Click the Advanced icon at the top of the dialog box. The dialog box will now look similar to the following:

advanced options dialog box

  1. Click the Update tab.
  2. Confirm that the checkbox in front of Automatically install updates (recommended:improved security) has a check mark. If it does not, click in the checkbox to enter one.
  3. Click OK.

How to Back Up Your Firefox Profile Folder (Windows XP, Vista, and Windows 7)

Your Firefox bookmark file and other browser settings are stored on your desktop computer in a folder called "Profile." If your hard drive crashes or your profile becomes corrupted, these files may be overwritten or lost—meaning you will lose all your bookmark settings, data settings, etc. You can prevent this data loss by properly backing up your Firefox profile folder.

NOTE
To access your profile folder on a Windows computer, your system must be set to view all files. On Windows XP and Vista computers, the default setting is not set to view all files.

If your computer is not currently set to view all files, you can use Windows Explorer to enable this option:

  1. Open Windows Explorer as you normally do or by following these steps:
    1. Click Start | All Programs.
    2. Click Accessories.
    3. Click Windows Explorer.
    4. From the Tools menu, click Folder Options.
    5. Click the View tab.
    6. Double-click the folder labeled Hidden files and folders.
    7. Click the radio button in front of the Show hidden files and folders option.
    8. Click Apply.
    9. Click OK.
  1. If you use a Windows XP computer, click the following path to the Firefox profiles folder:

    C:\Documents and Settings\[User Name]\Application Data\Mozilla\Firefox\Profiles\

  2. If you use a Windows Vista computer, click the following path to the Firefox profiles folder:
  3. C:\users\[User Name]\AppData\Roaming\Mozilla\Firefox\Profiles\

  4. If you use a Windows 7 computer, click the following path to the Firefox profiles folder:

    C:\Users\[User Name]\AppData\Roaming\Mozilla\Firefox\Profiles\

  5. Copy the Profiles folder to a USB Flash drive or other removable media.

Last updated 8/29/12